Intermittent student connection issues
Incident Report for iClicker Cloud
Resolved
Polling connections have been restored and the cause identified. The team continues to monitor the system to ensure stability.
Posted Sep 14, 2018 - 14:30 EDT
Investigating
iClicker is currently experiencing issues with connections to polling sessions through iClicker Cloud & Classic with Reef enabled. Reports also indicate difficulty starting/ending polling from the Instructor application.

Our team continues to investigate an expedient resolution.
Posted Sep 14, 2018 - 14:08 EDT
This incident affected: iClicker Cloud: Instructor Desktop Application, iClicker Student: iOS App, iclicker Student: Android App, and iClicker Student: Website.