Reef Student Application currently not availalbe
Incident Report for iClicker Cloud
Resolved
This incident has been resolved.
Posted Aug 16, 2017 - 10:41 EDT
Investigating
Our monitoring and verification show that the Reef Student application is currently unavailable. Our engineering team is investigating and we will provide updates as they are available. Thank you in advance for your patience while we investigate and correct the issue.
Posted Aug 16, 2017 - 10:30 EDT