CANVAS Instructor Maintenance

Incident Report for iClicker Cloud

Monitoring

We are continuing to monitor an issue that some instructors may have encountered using the Canvas Roster and Grade Sync (RGS) integration, where they saw an "unknown client" error due to a change in iClicker's inherited developer key. We advise impacted customers to disconnect from RGS, then reconnect, where they will be prompted to sign into Canvas and authorize the new key by following these instructions: https://mhe.my.site.com/iclicker/s/article/Instructor-Guide-iClicker-Cloud-Roster-Grade-Sync-with-Canvas. Please continue to follow the Canvas Instructure status page (https://status.instructure.com/) for additional details.
Posted May 01, 2026 - 13:22 EDT

Investigating

Instructors using the Canvas Roster and Grade Sync (RGS) integration are seeing an "unknown client" error due to a change in iClicker's inherited developer key.  A support case has been opened with Instructure and we will provide an update as we learn more. Follow https://status.instructure.com/ for additional details.
Posted May 01, 2026 - 12:33 EDT