iClicker Cloud degraded performance

Incident Report for iClicker Cloud

Resolved

This incident has been resolved.
Posted Sep 05, 2019 - 12:09 EDT

Update

All reports are that the situation has stabilized. Student experience should be fully operational at this time.
Posted Sep 05, 2019 - 12:09 EDT

Investigating

Our team is aware of and investigating a degradation in performance affecting students' ability to join courses through mobile and web interfaces. Some students may not be able to join an instructor's course or may experience slow response from the servers.
Posted Sep 05, 2019 - 11:58 EDT
This incident affected: iClicker Student: iOS App, iclicker Student: Android App, and iClicker Student: Website.